CruiseFish Forum


    Australia
    joined Apr 2010
    post 2/34
    cruiser #90
    Bad display of mouseover prices and missing history graph (IE8)

    Hi,

    For the past couple of weeks I've noticed that when you mouseover prices they aren't correctly formatter, just in black over the full list of prices so hard to read (instead of with the yellow background, and on the right hand side).

    Also, the price history graph beside each cruiseline doesn't appear, only the X and Y axes do, but the centre is empty (white).

    This is on a computer with IE8. When I use another computer with IE7 it doesn't have that issue. Is there a problem with the config for IE8 or anything that can be done?

    relaxing with Ernie
    Quebec, QC, Canada
    joined Apr 2010
    post 121/625
    cruiser #3
    Re: Bad display of mouseover prices and missing history graph (IE8)

    Hi,

    As IE doesn't support the HTML5 canvas feature, price popups and graphs have to rely on a external javascript library called explorercanvas http://code.google.com/p/explorercanvas/ which is supposed to work well. I just tried it on my own IE8 and it seems to work fine.

    Does any other IE8 user have that problem?

    In general IE is a pretty bad browser (buggy, non-standard conformant, open to malware and script attacks) and I can only recommend that CF users try out Firefox 4 http://www.getfirefox.com/ or Google Chrome http://www.google.com/chrome/ both excellent and mostly secure browsers if kept up-to-date.


    cruisefish.net administrator

    scream.jpg
    joined Aug 2010
    post 12/31
    cruiser #3484
    Re: Bad display of mouseover prices and missing history graph (IE8)

    Sometimes when I initially mouse over the US$ prices column I get Canadian $ prices displayed, then afterwards it corrects itself.... very strange. Not really a problem though.

    Australia
    joined Apr 2010
    post 3/34
    cruiser #90
    Re: Bad display of mouseover prices and missing history graph (IE8)

    Thanks for the quick feedback and explanation. It was very helpful and enabled me to trace that the issue was on this computer. I've gone back to an earlier restore point and everything is the way it should be again.

    Thanks for taking the time too!

    Australia
    joined Apr 2010
    post 6/34
    cruiser #90
    Re: Bad display of mouseover prices and missing history graph (IE8)

    Hi again,

    As a follow on to the above, I've now switched to IE9 on Windows 7. From a fresh image, there was no issue with the price history. However the price history graph does not appear on the cruise line pages e.g. RCCL.

    Even though this is IE9, it sounds like it may be due to using the underlying structure as before. Are you able to test on your build?

    Thanks,

    relaxing with Ernie
    Quebec, QC, Canada
    joined Apr 2010
    post 167/625
    cruiser #3
    Re: Bad display of mouseover prices and missing history graph (IE8)

    On July 09, 2011 at 12:57 PM, odysseus292 wrote:

    Even though this is IE9, it sounds like it may be due to using the underlying structure as before. Are you able to test on your build?

    Graphs should now appear on IE9, otherwise tell me.

    Thanks,


    cruisefish.net administrator

    Australia
    joined Apr 2010
    post 7/34
    cruiser #90
    Re: Bad display of mouseover prices and missing history graph (IE8)

    Thanks again for your help, looks fine now.